summaryrefslogtreecommitdiff
path: root/acct-user/sshd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /acct-user/sshd
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'acct-user/sshd')
-rw-r--r--acct-user/sshd/Manifest2
-rw-r--r--acct-user/sshd/metadata.xml8
-rw-r--r--acct-user/sshd/sshd-0.ebuild15
3 files changed, 25 insertions, 0 deletions
diff --git a/acct-user/sshd/Manifest b/acct-user/sshd/Manifest
new file mode 100644
index 000000000000..6ef5731ad0d0
--- /dev/null
+++ b/acct-user/sshd/Manifest
@@ -0,0 +1,2 @@
+EBUILD sshd-0.ebuild 274 BLAKE2B 1a2b901a3daa6acf6a7a2b808ec1a772925c3696485571c9cd859496b52638ca2c3e64ea415fca4f65bdcde0488bc4c5faaf5571d2e7f28cfa954d0b6aba7346 SHA512 4c3856ef2c73749079cbd5595aa44d47f1951b9d2ca5b8494f37ab1ff97977d65fafa420c23481014b249d30cfe0e766ed8538700b2aa8212d04ee711f7951cf
+MISC metadata.xml 263 BLAKE2B da35927a73cc22621ec3170a872817bc1f2e91967dd369f21f6543ce2a02e995eb654ab2c1209bae764ef194788828e00daf5d559d3a26926e6912838075dc7f SHA512 b25a1229f571493fdde40749d60d17d411676854bc3f73810e15edac8a2a930d3633f46a6f7f5a7ec6cf7f36b9ef690a7e03916c7c76869315f5ba1f862fd0f0
diff --git a/acct-user/sshd/metadata.xml b/acct-user/sshd/metadata.xml
new file mode 100644
index 000000000000..3e60a9a347a4
--- /dev/null
+++ b/acct-user/sshd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/acct-user/sshd/sshd-0.ebuild b/acct-user/sshd/sshd-0.ebuild
new file mode 100644
index 000000000000..06703c1956ba
--- /dev/null
+++ b/acct-user/sshd/sshd-0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="User for ssh"
+
+ACCT_USER_ID=22
+ACCT_USER_HOME=/var/empty
+ACCT_USER_HOME_OWNER=root:root
+ACCT_USER_GROUPS=( sshd )
+
+acct-user_add_deps