summaryrefslogtreecommitdiff
path: root/acct-user/spamd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /acct-user/spamd
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'acct-user/spamd')
-rw-r--r--acct-user/spamd/Manifest2
-rw-r--r--acct-user/spamd/metadata.xml13
-rw-r--r--acct-user/spamd/spamd-0.ebuild25
3 files changed, 40 insertions, 0 deletions
diff --git a/acct-user/spamd/Manifest b/acct-user/spamd/Manifest
new file mode 100644
index 000000000000..596dfee1f1ca
--- /dev/null
+++ b/acct-user/spamd/Manifest
@@ -0,0 +1,2 @@
+EBUILD spamd-0.ebuild 731 BLAKE2B 0f219605b86301fdd33a1cf0d4a2d45d3f97167de46b1cebaa45c010a1b4faabd42e92b69ef3d39c83bff145889fa6a6abdd66aec236c91758911ce57e4bf5e3 SHA512 ed22f0112627def013342d1998f5580220cd078dd03dcee6801c332dabfda17680176ae9ca9e0ee1e950f3aac897b3a364bc04f6c097a8e9598610972d66e3d3
+MISC metadata.xml 400 BLAKE2B c742063222091176da4498b768820a52a0fb382f5c7f4ebe98660c0de5c47850b17bd5aaaf35d0ce17ceba44a0e62050366686c081929dc8c624f7d5709c717b SHA512 415a2cc228c2b71cc55a9a6d6dfb413ed1bdd5c559a37406d15c6ffb0f212ea0a04aeb4c029ac62306c8fdd363d5d950d83033e2ef427bcedafa80e31363ab30
diff --git a/acct-user/spamd/metadata.xml b/acct-user/spamd/metadata.xml
new file mode 100644
index 000000000000..265493eecbee
--- /dev/null
+++ b/acct-user/spamd/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo_bugs_peep@parallaxshift.com</email>
+ <name>Philippe Chaintreuil</name>
+ </maintainer>
+
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/acct-user/spamd/spamd-0.ebuild b/acct-user/spamd/spamd-0.ebuild
new file mode 100644
index 000000000000..e4fcb0a0378a
--- /dev/null
+++ b/acct-user/spamd/spamd-0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="User for the SpamAssassin daemon"
+
+ACCT_USER_ID=337
+ACCT_USER_GROUPS=( "${PN}" )
+# The spamd daemon runs as this user. Use a real home directory so
+# that it can hold SA configuration.
+#
+# Since spamd's home contains user-modifiable config files, it's
+# a violation of the Linux FHS for it to be here, but it's been
+# decided it can't be in /home/.
+#
+# - https://github.com/gentoo/gentoo/pull/14055#issuecomment-582929503
+# - https://archives.gentoo.org/gentoo-dev/message/790294f7a46496aecd0056289c4b6d08
+#
+ACCT_USER_HOME="/var/lib/spamd"
+ACCT_USER_HOME_PERMS=0700
+
+acct-user_add_deps