summaryrefslogtreecommitdiff
path: root/acct-user/scponly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /acct-user/scponly
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'acct-user/scponly')
-rw-r--r--acct-user/scponly/Manifest2
-rw-r--r--acct-user/scponly/metadata.xml12
-rw-r--r--acct-user/scponly/scponly-0.ebuild15
3 files changed, 29 insertions, 0 deletions
diff --git a/acct-user/scponly/Manifest b/acct-user/scponly/Manifest
new file mode 100644
index 000000000000..79f8e15a28e5
--- /dev/null
+++ b/acct-user/scponly/Manifest
@@ -0,0 +1,2 @@
+EBUILD scponly-0.ebuild 373 BLAKE2B aa3b88da4f047b47f60af61b548e10a8c0d3a196c31442ddb4d93dfeac3e80c18d270d4156169ac977d69dfd9af24d0bdecf79310c6b45623ea7f8df03239083 SHA512 6270f93cf62d2c5fb2021cdc996389b865ccc5d6e12db1be9df8c92b0b42ae5ce117b88c35db086486979de6763c92a45054ca5cb02273cbdc5c3ad0bbbf1f02
+MISC metadata.xml 366 BLAKE2B 2dfc36224a99a053e04ce8888b2fa2a03c3a7649fe62ac7f66f7a5ac8829a913457ed767d2fa4fc6503628a747594de5d89a028f41f09f6c4ede6cc109b8e922 SHA512 1bef34b0f7835d77fb56fe12149dc3f10a3695c8303118420065ccb48607d6a90da2ff999747778f251e4a0ee1525a30df49df1d60699cb32b00dd357e8a99c5
diff --git a/acct-user/scponly/metadata.xml b/acct-user/scponly/metadata.xml
new file mode 100644
index 000000000000..16853472f6b4
--- /dev/null
+++ b/acct-user/scponly/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hlein@korelogic.com</email>
+ <name>Hank Leininger</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/acct-user/scponly/scponly-0.ebuild b/acct-user/scponly/scponly-0.ebuild
new file mode 100644
index 000000000000..86b78a5ccf6f
--- /dev/null
+++ b/acct-user/scponly/scponly-0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="user for chrooted scponly"
+ACCT_USER_ID=239
+ACCT_USER_GROUPS=( scponly )
+# Not a typo. scponly uses the trailing // to identify the chroot dir.
+ACCT_USER_HOME=/var/chroot/scponly//
+ACCT_USER_HOME_OWNER=root:root
+
+acct-user_add_deps