summaryrefslogtreecommitdiff
path: root/acct-user/puppetdb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /acct-user/puppetdb
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'acct-user/puppetdb')
-rw-r--r--acct-user/puppetdb/Manifest2
-rw-r--r--acct-user/puppetdb/metadata.xml8
-rw-r--r--acct-user/puppetdb/puppetdb-0.ebuild14
3 files changed, 24 insertions, 0 deletions
diff --git a/acct-user/puppetdb/Manifest b/acct-user/puppetdb/Manifest
new file mode 100644
index 000000000000..2d8572c63c39
--- /dev/null
+++ b/acct-user/puppetdb/Manifest
@@ -0,0 +1,2 @@
+EBUILD puppetdb-0.ebuild 320 BLAKE2B e23ace284f713be4ec1f12638d361c31d956ffbdd01ef4fa751d8c10555a026c7c8d959dee5c04d47fb49bd339768a0ab299d349d95871c0f0879ce9ec4ae01d SHA512 040f9ecdb9f0b415857240ddd676917d340ef4793a350efd090c9436461902c609c17e73442ce2273d7ad020e3f2a88f9c60c95c67788368c32ad5adebb6a5ee
+MISC metadata.xml 254 BLAKE2B 731c7015b1415180253ab851fc24ad031153050aa0feff41781a5c16ced70787ca132b4fe53adaa8a189de944dda987c65081162895f1f03d68dc77405308fa7 SHA512 49faa8aa0aef31db638fe291aa55ff114f96fd9f9b2c733f88b326b44f3e9dbf627e825de7c41d45f208b2b7e5e6cd5c03e6fee3fa6013625ce7ce158bbc9a31
diff --git a/acct-user/puppetdb/metadata.xml b/acct-user/puppetdb/metadata.xml
new file mode 100644
index 000000000000..3ffdeb4af3b5
--- /dev/null
+++ b/acct-user/puppetdb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/acct-user/puppetdb/puppetdb-0.ebuild b/acct-user/puppetdb/puppetdb-0.ebuild
new file mode 100644
index 000000000000..7f70113f6559
--- /dev/null
+++ b/acct-user/puppetdb/puppetdb-0.ebuild
@@ -0,0 +1,14 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="User for the puppetdb service"
+ACCT_USER_ID=456
+ACCT_USER_HOME=/opt/puppetlabs/server/data/puppetserver
+ACCT_USER_HOME_PERMS=0770
+ACCT_USER_GROUPS=( puppetdb )
+
+acct-user_add_deps