summaryrefslogtreecommitdiff
path: root/acct-user/pgagent/pgagent-0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /acct-user/pgagent/pgagent-0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'acct-user/pgagent/pgagent-0.ebuild')
-rw-r--r--acct-user/pgagent/pgagent-0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/acct-user/pgagent/pgagent-0.ebuild b/acct-user/pgagent/pgagent-0.ebuild
new file mode 100644
index 000000000000..da03477a46a1
--- /dev/null
+++ b/acct-user/pgagent/pgagent-0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit acct-user
+
+DESCRIPTION="pgagent program user"
+ACCT_USER_ID=135
+ACCT_USER_SHELL=/bin/bash
+ACCT_USER_HOME=/var/lib/pgagent
+ACCT_USER_GROUPS=( pgagent )
+acct-user_add_deps
+SLOT="0"
+
+pkg_postinst() {
+ ewarn "The home directory has changed for pgagent."
+ ewarn "You should move files, especially .pgpass, from:"
+ ewarn " /home/pgagent"
+ ewarn "To:"
+ ewarn " ${ACCT_USER_HOME}"
+}