summaryrefslogtreecommitdiff
path: root/xfce-base/xfce4-session/xfce4-session-4.10.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/xfce4-session/xfce4-session-4.10.1.ebuild')
-rw-r--r--xfce-base/xfce4-session/xfce4-session-4.10.1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/xfce-base/xfce4-session/xfce4-session-4.10.1.ebuild b/xfce-base/xfce4-session/xfce4-session-4.10.1.ebuild
new file mode 100644
index 00000000..1f242af8
--- /dev/null
+++ b/xfce-base/xfce4-session/xfce4-session-4.10.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-session/xfce4-session-4.10.1.ebuild,v 1.6 2014/01/28 14:17:20 ago Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A session manager for the Xfce desktop environment"
+HOMEPAGE="http://docs.xfce.org/xfce/xfce4-session/start"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug systemd udev +xscreensaver"
+
+COMMON_DEPEND=">=dev-libs/dbus-glib-0.100
+ x11-apps/iceauth
+ x11-libs/libSM
+ >=x11-libs/libwnck-2.30:1
+ x11-libs/libX11
+ >=xfce-base/libxfce4util-4.10.1
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/xfconf-4.10
+ !xfce-base/xfce-utils
+ systemd? ( >=sys-auth/polkit-0.100 )"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xrdb
+ x11-misc/xdg-user-dirs
+ udev? ( >=sys-power/upower-0.9.20 )
+ xscreensaver? ( || (
+ >=x11-misc/xscreensaver-5.15
+ gnome-extra/gnome-screensaver
+ >=x11-misc/xlockmore-5.38
+ >=x11-misc/slock-1
+ ) )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable systemd)
+ --with-xsession-prefix="${EPREFIX}"/usr
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS BUGS ChangeLog NEWS README TODO )
+}
+
+src_install() {
+ xfconf_src_install
+
+ local sessiondir=/etc/X11/Sessions
+ echo startxfce4 > "${T}"/Xfce4
+ exeinto ${sessiondir}
+ doexe "${T}"/Xfce4
+ dosym Xfce4 ${sessiondir}/Xfce
+}