summaryrefslogtreecommitdiff
path: root/x11-themes/redcore-artwork-core/redcore-artwork-core-1701.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/redcore-artwork-core/redcore-artwork-core-1701.ebuild')
-rw-r--r--x11-themes/redcore-artwork-core/redcore-artwork-core-1701.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-themes/redcore-artwork-core/redcore-artwork-core-1701.ebuild b/x11-themes/redcore-artwork-core/redcore-artwork-core-1701.ebuild
new file mode 100644
index 00000000..da6faf1e
--- /dev/null
+++ b/x11-themes/redcore-artwork-core/redcore-artwork-core-1701.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2016 Redcore Linux
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Offical Redcore Linux Core Artwork"
+HOMEPAGE="http://redcorelinux.org"
+SRC_URI="http://redcorelinux.org/distfiles/${CATEGORY}/${PN}/"${PN}"-${PV}.tar.xz"
+
+LICENSE="CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE=""
+RDEPEND="sys-apps/findutils"
+
+S="${WORKDIR}"/"${PN}"
+
+src_install() {
+ # Cursors
+ insinto /usr/share/cursors/xorg-x11/
+ doins -r "${S}"/mouse/Hacked-Red
+
+ # Wallpapers
+ insinto /usr/share/backgrounds/
+ doins -r "${S}"/background/nature
+
+ # Logos
+ insinto /usr/share/pixmaps/
+ doins "${S}"/logo/*.png
+
+ # Plymouth theme
+
+ insinto /usr/share/plymouth
+ doins "${S}"/plymouth/bizcom.png # back to our bizcom
+ insinto /usr/share/plymouth/themes
+ doins -r "${S}"/plymouth/themes/redcore
+
+ # Apply our tricks
+
+ insinto /usr/share/cursors/xorg-x11
+ dosym Hacked-Red /usr/share/cursors/xorg-x11/default || "Hacked-Red not found" #set default xcursor
+}