summaryrefslogtreecommitdiff
path: root/x11-terms/qterminal/qterminal-0.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/qterminal/qterminal-0.9.0.ebuild')
-rw-r--r--x11-terms/qterminal/qterminal-0.9.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-terms/qterminal/qterminal-0.9.0.ebuild b/x11-terms/qterminal/qterminal-0.9.0.ebuild
new file mode 100644
index 00000000..e1727d64
--- /dev/null
+++ b/x11-terms/qterminal/qterminal-0.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Qt-based multitab terminal emulator"
+HOMEPAGE="https://github.com/lxde/qterminal"
+SRC_URI="https://github.com/lxde/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ ~x11-libs/qtermwidget-${PV}
+"
+DEPEND="${RDEPEND}"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}