summaryrefslogtreecommitdiff
path: root/virtual/rust/rust-1.314.1337-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/rust/rust-1.314.1337-r2.ebuild')
-rw-r--r--virtual/rust/rust-1.314.1337-r2.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.314.1337-r2.ebuild b/virtual/rust/rust-1.314.1337-r2.ebuild
new file mode 100644
index 00000000..5ab25d51
--- /dev/null
+++ b/virtual/rust/rust-1.314.1337-r2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+SLOT="0/llvm-14"
+KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="+rustfmt system-llvm"
+
+BDEPEND=""
+RDEPEND="|| (
+ >=dev-lang/rust-1.64.0[rustfmt?,system-llvm=,${MULTILIB_USEDEP}]
+)"