summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-12.2.1_p20230121-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc/gcc-12.2.1_p20230121-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-12.2.1_p20230121-r1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/sys-devel/gcc/gcc-12.2.1_p20230121-r1.ebuild b/sys-devel/gcc/gcc-12.2.1_p20230121-r1.ebuild
deleted file mode 100644
index 148aa276..00000000
--- a/sys-devel/gcc/gcc-12.2.1_p20230121-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-TOOLCHAIN_PATCH_DEV="sam"
-PATCH_VER="10"
-PATCH_GCC_VER="12.2.0"
-MUSL_VER="7"
-MUSL_GCC_VER="12.2.0"
-
-if [[ $(ver_cut 3) == 9999 ]] ; then
- MY_PV_2=$(ver_cut 2)
- if [[ ${MY_PV_2} == 0 ]] ; then
- MY_PV_2=0
- else
- MY_PV_2=$(($(ver_cut 2) - 1))
- fi
-
- # e.g. 12.2.9999 -> 12.1.1
- TOOLCHAIN_GCC_PV=$(ver_cut 1).${MY_PV_2}.$(($(ver_cut 3) - 9998))
-elif [[ -n ${TOOLCHAIN_GCC_RC} ]] ; then
- # Cheesy hack for RCs
- MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1))).$((($(ver_cut 3) - 1)))-RC-$(ver_cut 5)
- MY_P=${PN}-${MY_PV}
- GCC_TARBALL_SRC_URI="https://gcc.gnu.org/pub/gcc/snapshots/${MY_PV}/${MY_P}.tar.xz"
- TOOLCHAIN_SET_S=no
- S="${WORKDIR}"/${MY_P}
-fi
-
-inherit toolchain
-
-# Needs to be after inherit (for now?), bug #830908
-EGIT_BRANCH=releases/gcc-$(ver_cut 1)
-
-# Don't keyword live ebuilds
-if ! tc_is_live && [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ~ppc ppc64 ~riscv ~s390 sparc ~x86"
-fi
-
-# Technically only if USE=hardened *too* right now, but no point in complicating it further.
-# If GCC is enabling CET by default, we need glibc to be built with support for it.
-# bug #830454
-RDEPEND="elibc_glibc? ( sys-libs/glibc[cet(-)?] )"
-DEPEND="${RDEPEND}"
-BDEPEND=">=${CATEGORY}/binutils-2.30[cet(-)?]"
-
-src_prepare() {
- toolchain_src_prepare
-
- eapply_user
-}