summaryrefslogtreecommitdiff
path: root/sys-boot/etcher/etcher-1.18.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/etcher/etcher-1.18.4.ebuild')
-rw-r--r--sys-boot/etcher/etcher-1.18.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-boot/etcher/etcher-1.18.4.ebuild b/sys-boot/etcher/etcher-1.18.4.ebuild
new file mode 100644
index 00000000..39b988d0
--- /dev/null
+++ b/sys-boot/etcher/etcher-1.18.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="balenaEtcher"
+
+inherit eutils
+
+DESCRIPTION="Flash OS images to SD cards & USB drives, safely and easily."
+HOMEPAGE="https://etcher.io/"
+SRC_URI="https://github.com/balena-io/${PN}/releases/download/v${PV}/${MY_PN}-${PV}-x64.AppImage"
+
+LICENSE="GPL2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/nss
+ media-libs/alsa-lib
+ sys-apps/lsb-release
+ x11-libs/gtk+:2
+ x11-libs/libXtst
+ x11-libs/libnotify"
+RDEPEND="${DEPEND}"
+
+RESTRICT="mirror strip"
+
+S="${DISTDIR}"
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ newbin ${MY_PN}-${PV}-x64.AppImage ${MY_PN}
+ domenu ${FILESDIR}/${MY_PN}.desktop
+}