summaryrefslogtreecommitdiff
path: root/net-wireless/cowpatty/cowpatty-4.6-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/cowpatty/cowpatty-4.6-r4.ebuild')
-rw-r--r--net-wireless/cowpatty/cowpatty-4.6-r4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-wireless/cowpatty/cowpatty-4.6-r4.ebuild b/net-wireless/cowpatty/cowpatty-4.6-r4.ebuild
new file mode 100644
index 00000000..7beab82e
--- /dev/null
+++ b/net-wireless/cowpatty/cowpatty-4.6-r4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="WLAN tools for bruteforcing 802.11 WPA/WPA2 keys"
+HOMEPAGE="http://www.willhackforsushi.com/?page_id=50"
+SRC_URI="http://www.willhackforsushi.com/code/${PN}/${PV}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ epatch "${FILESDIR}"/cowpatty-4.6-fixup14.patch
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dobin cowpatty genpmk || die "dobin failed"
+ dodoc AUTHORS CHANGELOG FAQ INSTALL README TODO dict *.dump
+}