summaryrefslogtreecommitdiff
path: root/net-p2p/sopcast-bin/sopcast-bin-3.2.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/sopcast-bin/sopcast-bin-3.2.6.ebuild')
-rw-r--r--net-p2p/sopcast-bin/sopcast-bin-3.2.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-p2p/sopcast-bin/sopcast-bin-3.2.6.ebuild b/net-p2p/sopcast-bin/sopcast-bin-3.2.6.ebuild
new file mode 100644
index 00000000..94bcede2
--- /dev/null
+++ b/net-p2p/sopcast-bin/sopcast-bin-3.2.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+MY_P="sp-auth"
+
+DESCRIPTION="SopCast free P2P Internet TV binary"
+LICENSE="SopCast-unknown-license"
+HOMEPAGE="http://www.sopcast.com/"
+SRC_URI="http://sopcast-player.googlecode.com/files/${MY_P}-${PV}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+QA_PRESTRIPPED="opt/${PN}/${PN}"
+
+# All dependencies might not be listed, since the binary blob's homepage only lists libstdc++
+RDEPEND="amd64? ( app-emulation/emul-linux-x86-compat )
+ x86? ( >=virtual/libstdc++-3.3 )"
+
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ exeinto /opt/${PN}
+ newexe sp-sc-auth ${PN} || die "newexe failed"
+ dosym /opt/${PN}/${PN} /usr/bin/${PN}
+ dodoc Readme || die "dodoc failed"
+}