summaryrefslogtreecommitdiff
path: root/net-im/utox/utox-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/utox/utox-9999.ebuild')
-rw-r--r--net-im/utox/utox-9999.ebuild18
1 files changed, 5 insertions, 13 deletions
diff --git a/net-im/utox/utox-9999.ebuild b/net-im/utox/utox-9999.ebuild
index 77c583a8..41676f8e 100644
--- a/net-im/utox/utox-9999.ebuild
+++ b/net-im/utox/utox-9999.ebuild
@@ -1,23 +1,22 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
-inherit eutils fdo-mime git-2 gnome2-utils toolchain-funcs
+inherit fdo-mime gnome2-utils toolchain-funcs git-2
DESCRIPTION="Lightweight Tox client"
-HOMEPAGE="https://github.com/notsecure/uTox"
+HOMEPAGE="https://github.com/notsecure/uTox.git"
EGIT_REPO_URI="git://github.com/notsecure/uTox.git
https://github.com/notsecure/uTox.git"
LICENSE="GPL-3"
SLOT="0"
-IUSE="+dbus +filter_audio"
+IUSE="+dbus"
RDEPEND="net-libs/tox[av]
media-libs/freetype
- filter_audio? ( media-libs/libfilteraudio )
media-libs/libv4l
media-libs/libvpx
media-libs/openal
@@ -32,10 +31,6 @@ src_prepare() {
}
src_configure() {
- if use filter_audio && [ "${PROFILE_IS_HARDENED}" = 1 ]; then
- ewarn "Building µTox with support for filter_audio using hardened profile results in"
- ewarn "crash upon start. For details, see https://github.com/notsecure/uTox/issues/844"
- fi
# respect CFLAGS
sed -i \
-e '/CFLAGS/s# -g ##' \
@@ -43,10 +38,7 @@ src_configure() {
}
src_compile() {
- emake \
- CC="$(tc-getCC)" \
- DBUS=$(usex dbus "1" "0") \
- FILTER_AUDIO=$(usex filter_audio "1" "0")
+ emake CC="$(tc-getCC)" DBUS=$(usex dbus "1" "0")
}
src_install() {