summaryrefslogtreecommitdiff
path: root/net-im/blight/blight-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/blight/blight-9999.ebuild')
-rw-r--r--net-im/blight/blight-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/net-im/blight/blight-9999.ebuild b/net-im/blight/blight-9999.ebuild
index ce4a0b83..3648b627 100644
--- a/net-im/blight/blight-9999.ebuild
+++ b/net-im/blight/blight-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit git-2
+inherit eutils git-2
DESCRIPTION="Cross-platform graphical user interface for Tox written in Racket"
HOMEPAGE="https://github.com/lehitoskin/blight"
@@ -14,19 +14,22 @@ LICENSE="GPL-3"
SLOT="0"
RDEPEND="net-libs/tox
- >=dev-db/sqlite-3.8.2
- >=dev-scheme/racket-6.0.1[X]"
+ >=dev-db/sqlite-3.8.6
+ >=dev-scheme/racket-6.0.1[X]
+ dev-scheme/libtoxcore-racket
+ dev-scheme/libopenal-racket"
src_prepare() {
- raco pkg install --no-setup github://github.com/lehitoskin/libtoxcore-racket/master
epatch "$FILESDIR/${P}.patch"
epatch_user
}
src_compile() {
- emake
+ emake blight
+ emake blight-repl
}
src_install() {
- emake DESTDIR="${D}/usr" install
+ emake DESTDIR="${D}/usr" install-blight
+ emake DESTDIR="${D}/usr" install-repl
}