summaryrefslogtreecommitdiff
path: root/media-video/ffmulticonverter/ffmulticonverter-1.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/ffmulticonverter/ffmulticonverter-1.8.0.ebuild')
-rw-r--r--media-video/ffmulticonverter/ffmulticonverter-1.8.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-video/ffmulticonverter/ffmulticonverter-1.8.0.ebuild b/media-video/ffmulticonverter/ffmulticonverter-1.8.0.ebuild
new file mode 100644
index 00000000..17c87fcc
--- /dev/null
+++ b/media-video/ffmulticonverter/ffmulticonverter-1.8.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_5 )
+inherit eutils python-r1 distutils-r1
+DESCRIPTION="FF Multi Converter is a simple graphical application which enables you to convert audio, video, image and document files between all popular formats"
+HOMEPAGE="https://sourceforge.net/projects/ffmulticonv/"
+SRC_URI="mirror://sourceforge/project/ffmulticonv/${P}.tar.gz"
+
+LICENSE="GPLv3"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="+ffmpeg libav +imagemagick +unoconv"
+
+DEPEND="dev-lang/python:3.5
+ dev-python/PyQt5
+ ffmpeg? ( media-video/ffmpeg )
+ libav? ( media-video/libav )
+ imagemagick? ( media-gfx/imagemagick )
+ unoconv? ( app-office/unoconv )"
+RDEPEND="${DEPEND}"
+