summaryrefslogtreecommitdiff
path: root/mail-client/wavebox/wavebox-3.1.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/wavebox/wavebox-3.1.12.ebuild')
-rw-r--r--mail-client/wavebox/wavebox-3.1.12.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/mail-client/wavebox/wavebox-3.1.12.ebuild b/mail-client/wavebox/wavebox-3.1.12.ebuild
new file mode 100644
index 00000000..ecad6029
--- /dev/null
+++ b/mail-client/wavebox/wavebox-3.1.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils unpacker
+
+DESCRIPTION="Wavebox lets you bring all your web communication tools together for faster, smarter working. Gmail, Google Inbox, Outlook, Office 365, Slack, Trello & more"
+HOMEPAGE="https://wavebox.io"
+SRC_URI="https://github.com/${PN}/${PN}app/releases/download/v${PV}/Wavebox_3_1_12_linux_x86_64.deb"
+
+LICENSE="GPL2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/nss
+ gnome-base/gconf
+ media-libs/alsa-lib
+ sys-apps/lsb-release
+ x11-libs/gtk+:2
+ x11-libs/libXtst
+ x11-libs/libnotify"
+RDEPEND="${DEPEND}"
+
+RESTRICT="mirror"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ mv * "${D}" || die
+ fperms 0755 /opt/${PN}/Wavebox || die
+}