summaryrefslogtreecommitdiff
path: root/lxde-base/lxappearance/lxappearance-0.6.3-r1337.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'lxde-base/lxappearance/lxappearance-0.6.3-r1337.ebuild')
-rw-r--r--lxde-base/lxappearance/lxappearance-0.6.3-r1337.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/lxde-base/lxappearance/lxappearance-0.6.3-r1337.ebuild b/lxde-base/lxappearance/lxappearance-0.6.3-r1337.ebuild
new file mode 100644
index 00000000..612b0af7
--- /dev/null
+++ b/lxde-base/lxappearance/lxappearance-0.6.3-r1337.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="LXDE GTK+ theme switcher"
+HOMEPAGE="http://lxde.sourceforge.net"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~mips ppc x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="dbus"
+
+RDEPEND="x11-libs/gtk+:2
+ dbus? ( dev-libs/dbus-glib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/"${PN}"-desktop.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable dbus)
+}