summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/sisyphus/sisyphus-4.2107.0-r2.ebuild (renamed from app-portage/sisyphus/sisyphus-4.2107.0-r1.ebuild)6
1 files changed, 2 insertions, 4 deletions
diff --git a/app-portage/sisyphus/sisyphus-4.2107.0-r1.ebuild b/app-portage/sisyphus/sisyphus-4.2107.0-r2.ebuild
index 08d06e4b..a16601c1 100644
--- a/app-portage/sisyphus/sisyphus-4.2107.0-r1.ebuild
+++ b/app-portage/sisyphus/sisyphus-4.2107.0-r2.ebuild
@@ -69,11 +69,9 @@ pkg_postinst() {
# Make sure portage sees the new mirror configuration file
rm -rf "{EROOT}"etc/"${PN}"/mirrors.conf
- if ARCH="amd64"; then
+ if [[ $(uname -m) == "x86_64" ]] ; then
ln -sf "${EROOT}"etc/"${PN}"/"${PN}"-mirrors-amd64.conf "${EROOT}"etc/"${PN}"/mirrors.conf
- fi
-
- if ARCH="arm64"; then
+ elif [[ $(uname -m) == "aarch64" ]] ; then
ln -sf "${EROOT}"etc/"${PN}"/"${PN}"-mirrors-arm64.conf "${EROOT}"etc/"${PN}"/mirrors.conf
fi
}