summaryrefslogtreecommitdiff
path: root/app-portage/sisyphus-qt/sisyphus-qt-6.2305.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/sisyphus-qt/sisyphus-qt-6.2305.0.ebuild')
-rw-r--r--app-portage/sisyphus-qt/sisyphus-qt-6.2305.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-portage/sisyphus-qt/sisyphus-qt-6.2305.0.ebuild b/app-portage/sisyphus-qt/sisyphus-qt-6.2305.0.ebuild
new file mode 100644
index 00000000..c04351d3
--- /dev/null
+++ b/app-portage/sisyphus-qt/sisyphus-qt-6.2305.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2016-2020 Redcore Linux Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/-qt/}"
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit eutils python-single-r1 git-r3
+
+DESCRIPTION="A simple portage python wrapper which works like other package managers(apt-get/yum/dnf)"
+HOMEPAGE="http://redcorelinux.org"
+
+EGIT_REPO_URI="https://gitlab.com/redcore/sisyphus.git"
+EGIT_BRANCH="master"
+EGIT_COMMIT="78eca7889aebbc3e7f141f23a41eb9b3b79f3a69"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm64"
+IUSE=""
+
+DEPEND="dev-lang/python[sqlite]
+ ~app-portage/sisyphus-${PV}"
+RDEPEND="${DEPEND}
+ app-misc/tmux
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[designer,gui,widgets,${PYTHON_USEDEP}]
+ ')"
+
+src_install() {
+ emake DESTDIR="${D}"/ install-gui
+
+ # enforce the best available python implementation (CLI)
+ python_setup
+ python_fix_shebang "${ED}"/usr/share/"${MY_PN}"/"${MY_PN}"-gui.py
+}