summaryrefslogtreecommitdiff
path: root/app-emulation/steam/steam-1.0.0.45.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/steam/steam-1.0.0.45.ebuild')
-rw-r--r--app-emulation/steam/steam-1.0.0.45.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/app-emulation/steam/steam-1.0.0.45.ebuild b/app-emulation/steam/steam-1.0.0.45.ebuild
deleted file mode 100644
index 6a1e1ba2..00000000
--- a/app-emulation/steam/steam-1.0.0.45.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-EAPI=5
-
-inherit eutils
-
-DESCRIPTION="Digital distribution client bootstrap package"
-HOMEPAGE="http://steampowered.com/"
-SRC_URI="http://repo.steampowered.com/${PN}/pool/${PN}/s/${PN}/${PN}_${PV}.tar.gz"
-
-LICENSE="custom"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-EMUL_X86_VER=20120520
-
-RDEPEND="
- virtual/ttf-fonts
- dev-util/desktop-file-utils
- x11-themes/hicolor-icon-theme
- net-misc/curl
- sys-apps/dbus
- media-libs/freetype
- x11-libs/gdk-pixbuf
- gnome-extra/zenity
- amd64? (
- >=app-emulation/emul-linux-x86-xlibs-${EMUL_X86_VER}
- >=app-emulation/emul-linux-x86-soundlibs-${EMUL_X86_VER}
- >=app-emulation/emul-linux-x86-opengl-${EMUL_X86_VER}
- )
- x86? (
- media-libs/alsa-lib
- media-libs/mesa
- x11-libs/libX11
- )"
-
-S=${WORKDIR}/${PN}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- rm -rf "${D}"/usr/bin/steamdeps || die # we don't use apt-get
- dosym /bin/true /usr/bin/steamdeps || die # create blank steamdeps
-}