summaryrefslogtreecommitdiff
path: root/app-admin/vasile/vasile-1.1806-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/vasile/vasile-1.1806-r2.ebuild')
-rw-r--r--app-admin/vasile/vasile-1.1806-r2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-admin/vasile/vasile-1.1806-r2.ebuild b/app-admin/vasile/vasile-1.1806-r2.ebuild
new file mode 100644
index 00000000..59f7991c
--- /dev/null
+++ b/app-admin/vasile/vasile-1.1806-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2016-2018 Redcore Linux Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Versatile Advanced Script for ISO and Latest Enchantments"
+HOMEPAGE="https://redcorelinux.org"
+SRC_URI="https://gitlab.com/redcore/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND="sys-apps/gentoo-functions"
+RDEPEND="${DEPEND}
+ dev-libs/libisoburn
+ dev-vcs/git
+ sys-boot/grub:2
+ sys-kernel/dkms
+ sys-fs/mtools
+ sys-fs/squashfs-tools"
+
+PATCHES=( ${FILESDIR}/nuke-gitlab-switch-to-cgit.patch
+ ${FILESDIR}/switch-to-pagure.patch )
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_install() {
+ default
+ dosym ../../usr/bin/"${PN}".sh usr/bin/"${PN}"
+ dodir var/cache/packages
+ dodir var/cache/distfiles
+}
+
+_migration_warning() {
+ einfo ""
+ einfo "We nuked Gitlab due to service unreliability, vasile will use pagure.io from now on"
+ einfo ""
+ einfo "You must reset your current mode using:"
+ einfo ""
+ einfo "vasile --binmode (for binmode)"
+ einfo "vasile --mixedmode (for mixedmode)"
+ einfo "vasile --srcmode (for srcmode)"
+ einfo ""
+ einfo "Before reseting, you may want to backup any of your local changes (mixedmode && srcmode users only)"
+ einfo ""
+}
+
+pkg_postinst() {
+ chown portage:portage /var/cache/distfiles
+ chmod 775 /var/cache/distfiles
+ _migration_warning
+}