summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-messenger-plugin/xfce4-messenger-plugin-0.1.0.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
commit7224c1253228e5c29c78cb3f0f26ce34770f2356 (patch)
tree1684924656132935256e034f35f92abee6623265 /xfce-extra/xfce4-messenger-plugin/xfce4-messenger-plugin-0.1.0.ebuild
Added ebuilds for kogaion desktop
Diffstat (limited to 'xfce-extra/xfce4-messenger-plugin/xfce4-messenger-plugin-0.1.0.ebuild')
-rw-r--r--xfce-extra/xfce4-messenger-plugin/xfce4-messenger-plugin-0.1.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-messenger-plugin/xfce4-messenger-plugin-0.1.0.ebuild b/xfce-extra/xfce4-messenger-plugin/xfce4-messenger-plugin-0.1.0.ebuild
new file mode 100644
index 00000000..04724ab2
--- /dev/null
+++ b/xfce-extra/xfce4-messenger-plugin/xfce4-messenger-plugin-0.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-messenger-plugin/xfce4-messenger-plugin-0.1.0.ebuild,v 1.3 2012/04/09 21:20:55 ssuominen Exp $
+
+EAPI=5
+EAUTORECONF=yes
+inherit multilib xfconf
+
+DESCRIPTION="A plugin that listens DBus messages and displays received messages"
+HOMEPAGE="http://packages.qa.debian.org/x/xfce4-messenger-plugin.html"
+SRC_URI="https://launchpad.net/ubuntu/+archive/primary/+files/${PN}_${PV}.orig.tar.gz
+ https://launchpad.net/ubuntu/+archive/primary/+files/${PN}_${PV}-5.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/dbus-glib
+ >=dev-libs/glib-2
+ sys-apps/dbus
+ x11-libs/gtk+:2
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfcegui4-4.8
+ >=xfce-base/xfce4-panel-4.8"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ )
+
+ DOCS=( AUTHORS README TODO )
+}
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX=patch EPATCH_SOURCE="${WORKDIR}"/debian/patches epatch
+ xfconf_src_prepare
+}
+
+src_install() {
+ xfconf_src_install
+ exeinto /usr/share/doc/${PF}/scripts
+ doexe scripts/xfce-messenger-logtail
+}