summaryrefslogtreecommitdiff
path: root/xfce-extra/thunar-dropbox/thunar-dropbox-0.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@rogentos.ro>2015-03-03 13:18:39 +0200
committerV3n3RiX <venerix@rogentos.ro>2015-03-03 13:18:39 +0200
commit59257c20af50f8cf71398581f011c29268c22904 (patch)
tree4b66fc3b28a40c73f6b3ea33461ef405fc046b2d /xfce-extra/thunar-dropbox/thunar-dropbox-0.2.0.ebuild
parent1d4685ccb4462149a48358830b8578ece519f85f (diff)
cleaned some xfce ebuilds already in portage tree && add xfce 4.12 fresh ebuilds
Diffstat (limited to 'xfce-extra/thunar-dropbox/thunar-dropbox-0.2.0.ebuild')
-rw-r--r--xfce-extra/thunar-dropbox/thunar-dropbox-0.2.0.ebuild18
1 files changed, 15 insertions, 3 deletions
diff --git a/xfce-extra/thunar-dropbox/thunar-dropbox-0.2.0.ebuild b/xfce-extra/thunar-dropbox/thunar-dropbox-0.2.0.ebuild
index beeddfac..3f148481 100644
--- a/xfce-extra/thunar-dropbox/thunar-dropbox-0.2.0.ebuild
+++ b/xfce-extra/thunar-dropbox/thunar-dropbox-0.2.0.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
-inherit eutils waf-utils gnome2-utils
+EAPI=5
+inherit eutils gnome2-utils
DESCRIPTION="Plugin for Thunar that adds context-menu items for Dropbox"
HOMEPAGE="http://www.softwarebakery.com/maato/thunar-dropbox.html"
@@ -11,7 +11,7 @@ SRC_URI="http://www.softwarebakery.com/maato/files/${PN}/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE=""
COMMON_DEPEND="dev-libs/glib:2
@@ -28,6 +28,18 @@ src_prepare() {
epatch "${FILESDIR}/${P}-wscript.patch"
}
+src_configure() {
+ python2 waf configure --prefix=/usr
+}
+
+src_compile() {
+ python2 waf build
+}
+
+src_install() {
+ python2 waf install --destdir="${D}"
+}
+
pkg_preinst() {
gnome2_icon_savelist
}