summaryrefslogtreecommitdiff
path: root/xfce-base/exo/exo-0.10.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@gmail.com>2014-11-04 22:57:02 +0200
committerV3n3RiX <venerix@gmail.com>2014-11-04 22:57:02 +0200
commit0bb1fcb2a50a7beb3b463764ce451ea7b166d17b (patch)
treeaaac9cd5f0635acb4acec76cf07ee177e8bf9758 /xfce-base/exo/exo-0.10.2-r1.ebuild
parentbc607661cc2cd7b471953797b4009d079391f9df (diff)
bump exo to latest stable version from portage tree
Diffstat (limited to 'xfce-base/exo/exo-0.10.2-r1.ebuild')
-rw-r--r--xfce-base/exo/exo-0.10.2-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/xfce-base/exo/exo-0.10.2-r1.ebuild b/xfce-base/exo/exo-0.10.2-r1.ebuild
new file mode 100644
index 00000000..170bb9d5
--- /dev/null
+++ b/xfce-base/exo/exo-0.10.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.10.2-r1.ebuild,v 1.9 2014/07/18 19:56:07 ago Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Extensions, widgets and framework library with session support for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.30
+ dev-perl/URI
+ >=x11-libs/gtk+-2.24:2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-exo_str_looks_like_an_uri.patch )
+
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS TODO )
+}