summaryrefslogtreecommitdiff
path: root/x11-themes/rogentos-artwork-grub/rogentos-artwork-grub-2.1.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-10-27 18:38:05 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-10-27 18:38:05 +0200
commit24934e623441310f644e5f72855b0f2bf9f3cd1a (patch)
treea453939bf58199bc2c3ff27bcf0accf2b221c6c4 /x11-themes/rogentos-artwork-grub/rogentos-artwork-grub-2.1.ebuild
parent687f45092b4f4ccf33765cee7427f054bae22344 (diff)
Incoming! Moving Rogento.git to kogaion-desktop. Finally
Diffstat (limited to 'x11-themes/rogentos-artwork-grub/rogentos-artwork-grub-2.1.ebuild')
-rw-r--r--x11-themes/rogentos-artwork-grub/rogentos-artwork-grub-2.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-themes/rogentos-artwork-grub/rogentos-artwork-grub-2.1.ebuild b/x11-themes/rogentos-artwork-grub/rogentos-artwork-grub-2.1.ebuild
new file mode 100644
index 00000000..a7ca282e
--- /dev/null
+++ b/x11-themes/rogentos-artwork-grub/rogentos-artwork-grub-2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2004-2012 Sabayon
+# Copyright 2012 Rogentos
+# Distributed under the terms of the GNU General Public License v2
+# Maintainer BlackNoxis <stefan.cristian at rogentos.ro>
+
+EAPI=4
+
+inherit base mount-boot
+
+DESCRIPTION="Rogentos GRUB2 Images"
+HOMEPAGE="http://www.rogentos.ro"
+SRC_URI="http://pkg.rogentos.ro/~rogentos/distro/${CATEGORY}/${PN}/${PN}-${PV}.tar.gz"
+LICENSE="CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="!x11-themes/sabayon-artwork-grub"
+
+S="${WORKDIR}"
+
+src_install () {
+ dodir /usr/share/grub
+ insinto /usr/share/grub
+ doins default-splash.png
+}
+
+pkg_postinst() {
+ local dir="${ROOT}"boot/grub
+ cp "${ROOT}/usr/share/grub/default-splash.png" "${dir}/default-splash.png" || \
+ ewarn "cannot install default splash file!"
+}