summaryrefslogtreecommitdiff
path: root/x11-themes/redcore-artwork-core/redcore-artwork-core-1801.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-14 00:36:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-14 00:36:38 +0000
commitf1b16374c253d58cf9f51b3de533ae7b5ba7244f (patch)
tree37f8e8cf95fbe389a49ede5344c7f49927bd66b3 /x11-themes/redcore-artwork-core/redcore-artwork-core-1801.ebuild
parent8eb082c4f5d195be255832a8a39e03e2450729eb (diff)
x11-themes/redcore-artwork-core : version bump
Diffstat (limited to 'x11-themes/redcore-artwork-core/redcore-artwork-core-1801.ebuild')
-rw-r--r--x11-themes/redcore-artwork-core/redcore-artwork-core-1801.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-themes/redcore-artwork-core/redcore-artwork-core-1801.ebuild b/x11-themes/redcore-artwork-core/redcore-artwork-core-1801.ebuild
new file mode 100644
index 00000000..7dba1c82
--- /dev/null
+++ b/x11-themes/redcore-artwork-core/redcore-artwork-core-1801.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2016 Redcore Linux
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Offical Redcore Linux Core Artwork"
+HOMEPAGE="https://redcorelinux.org"
+SRC_URI="http://mirror.math.princeton.edu/pub/redcorelinux/distfiles/${P}.tar.xz"
+
+LICENSE="CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE=""
+RDEPEND="sys-apps/findutils"
+
+S="${WORKDIR}"/"${P}"
+
+src_install() {
+ # Cursors
+ insinto usr/share/cursors/xorg-x11/
+ doins -r mouse/Hacked-Red
+ dosym ../../../../usr/share/cursors/xorg-x11/Hacked-Red usr/share/cursors/xorg-x11/default
+
+ # Wallpapers
+ insinto usr/share/backgrounds/
+ doins -r background/nature
+
+ # Logos
+ insinto usr/share/pixmaps/
+ doins logo/*.png
+
+ # Plymouth theme
+
+ insinto usr/share/plymouth
+ doins plymouth/bizcom.png
+ insinto usr/share/plymouth/themes
+ doins -r plymouth/themes/redcore
+}
+
+pkg_postinst() {
+ # regenerate initramfs to include plymouth theme changes
+ dracut -f --no-hostonly-cmdline
+}