summaryrefslogtreecommitdiff
path: root/x11-themes/gnome-colors-common/gnome-colors-common-5.5.1-r12.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
commit7224c1253228e5c29c78cb3f0f26ce34770f2356 (patch)
tree1684924656132935256e034f35f92abee6623265 /x11-themes/gnome-colors-common/gnome-colors-common-5.5.1-r12.ebuild
Added ebuilds for kogaion desktop
Diffstat (limited to 'x11-themes/gnome-colors-common/gnome-colors-common-5.5.1-r12.ebuild')
-rw-r--r--x11-themes/gnome-colors-common/gnome-colors-common-5.5.1-r12.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-themes/gnome-colors-common/gnome-colors-common-5.5.1-r12.ebuild b/x11-themes/gnome-colors-common/gnome-colors-common-5.5.1-r12.ebuild
new file mode 100644
index 00000000..b5d6d1cc
--- /dev/null
+++ b/x11-themes/gnome-colors-common/gnome-colors-common-5.5.1-r12.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+SLREV=1
+inherit gnome2-utils
+
+DESCRIPTION="Colorized icons shared between all gnome-colors iconsets"
+HOMEPAGE="http://code.google.com/p/gnome-colors/"
+
+SRC_URI="http://gnome-colors.googlecode.com/files/gnome-colors-${PV}.tar.gz
+ branding? ( http://pkg2.rogentos.ro/~noxis/distro/${CATEGORY}/fdo-icons-rogentos${SLREV}.tar.gz )"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+branding"
+
+RDEPEND="x11-themes/gnome-icon-theme"
+DEPEND=""
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ if use branding; then
+ cp -r fdo-icons-rogentos/* ${PN} || die "Rogentos branding failed"
+ fi
+}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ dodir /usr/share/icons
+ insinto /usr/share/icons
+ doins -r "${WORKDIR}/${PN}" || die "Installing icons failed"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}