summaryrefslogtreecommitdiff
path: root/x11-themes/faba-icon-theme/faba-icon-theme-4.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-01-03 16:09:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-01-03 16:09:29 +0000
commitf0cd84a623f982bf08824ff154b80dfc7da16c75 (patch)
treee4e891b7e452c99b9ff97620bf633f72202abc96 /x11-themes/faba-icon-theme/faba-icon-theme-4.1.2.ebuild
parenta53b907d357eed428851596f8ff2088e111f27b7 (diff)
add faba+moka icon themes
Diffstat (limited to 'x11-themes/faba-icon-theme/faba-icon-theme-4.1.2.ebuild')
-rw-r--r--x11-themes/faba-icon-theme/faba-icon-theme-4.1.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-themes/faba-icon-theme/faba-icon-theme-4.1.2.ebuild b/x11-themes/faba-icon-theme/faba-icon-theme-4.1.2.ebuild
new file mode 100644
index 00000000..a2153a28
--- /dev/null
+++ b/x11-themes/faba-icon-theme/faba-icon-theme-4.1.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="Faba is a sexy and modern icon theme with Tango influences."
+HOMEPAGE="http://snwh.org"
+if [[ ${PV} == *9999* ]];then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/moka-project/faba-icon-theme.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/moka-project/faba-icon-theme/archive/v${PV}/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+ RESTRICT="mirror"
+fi
+
+LICENSE="LGPL-3.0"
+SLOT="0"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ eapply_user
+ eautoreconf
+}
+
+src_compile(){
+ emake DESTDIR="${D}" || die
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst(){
+ elog "Hi! Thanks for prefering Faba Icons."
+ elog "If you want to use some other variants, such as Moka, "
+ elog "please, install this theme first. Thanks."
+}