summaryrefslogtreecommitdiff
path: root/x11-misc/obconf-qt/obconf-qt-0.14.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-01 12:17:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-01 12:17:03 +0100
commitde7e3991e9a097f668c44ff90cd2ae881d5cafea (patch)
tree514f63a24e0c1ad3030f06eb506ceb32545fed05 /x11-misc/obconf-qt/obconf-qt-0.14.1.ebuild
parent830eeff978e127b06562b417af04d4b66765c3c5 (diff)
x11-misc/obconf-qt : version && EAPI bump
Diffstat (limited to 'x11-misc/obconf-qt/obconf-qt-0.14.1.ebuild')
-rw-r--r--x11-misc/obconf-qt/obconf-qt-0.14.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-misc/obconf-qt/obconf-qt-0.14.1.ebuild b/x11-misc/obconf-qt/obconf-qt-0.14.1.ebuild
new file mode 100644
index 00000000..d195189b
--- /dev/null
+++ b/x11-misc/obconf-qt/obconf-qt-0.14.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg-utils
+
+DESCRIPTION="Openbox window manager configuration tool"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=lxqt-base/lxqt-build-tools-0.6.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ sys-apps/sed
+ x11-wm/openbox:3
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}