summaryrefslogtreecommitdiff
path: root/x11-misc/lightdm-qt4/lightdm-qt4-1.4.0.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
commit7224c1253228e5c29c78cb3f0f26ce34770f2356 (patch)
tree1684924656132935256e034f35f92abee6623265 /x11-misc/lightdm-qt4/lightdm-qt4-1.4.0.ebuild
Added ebuilds for kogaion desktop
Diffstat (limited to 'x11-misc/lightdm-qt4/lightdm-qt4-1.4.0.ebuild')
-rw-r--r--x11-misc/lightdm-qt4/lightdm-qt4-1.4.0.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/lightdm-qt4/lightdm-qt4-1.4.0.ebuild b/x11-misc/lightdm-qt4/lightdm-qt4-1.4.0.ebuild
new file mode 100644
index 00000000..9020a0ee
--- /dev/null
+++ b/x11-misc/lightdm-qt4/lightdm-qt4-1.4.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit autotools eutils
+
+TRUNK_VERSION="1.4"
+REAL_PN="${PN/-qt4}"
+REAL_P="${P/-qt4}"
+DESCRIPTION="Qt4 libraries for LightDM"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/LightDM"
+SRC_URI="http://launchpad.net/${REAL_PN}/${TRUNK_VERSION}/${REAL_PV}/+download/${REAL_P}.tar.gz
+ mirror://gentoo/introspection-20110205.m4.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEPEND="~x11-misc/lightdm-base-${PV}"
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}"
+
+DOCS=( NEWS )
+S="${WORKDIR}/${REAL_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${REAL_PN}-1.2.0-fix-configure.patch
+ epatch_user
+
+ # Remove bogus Makefile statement. This needs to go upstream
+ sed -i /"@YELP_HELP_RULES@"/d help/Makefile.am || die
+ if has_version dev-libs/gobject-introspection; then
+ eautoreconf
+ else
+ AT_M4DIR=${WORKDIR} eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-introspection \
+ --enable-liblightdm-qt
+}
+
+src_compile() {
+ cd "${S}/liblightdm-qt" && \
+ emake
+}
+
+src_install() {
+ cd "${S}/liblightdm-qt" && \
+ emake DESTDIR="${ED}" install
+}