summaryrefslogtreecommitdiff
path: root/x11-libs/libX11/libX11-1.8.1-r10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-09 18:55:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-09 18:55:58 +0100
commitd674e773afec7568a84545d10eb3e4100aaf4d9f (patch)
treee808fe3e044c54b0fef6835731ec99137b5ff854 /x11-libs/libX11/libX11-1.8.1-r10.ebuild
parentc21d314ef74dd80392914fb24131d9e157dc4eb0 (diff)
x11-libs/libX11 : bugfix ( https://gitlab.freedesktop.org/xorg/lib/libx11/-/issues/157 )
Diffstat (limited to 'x11-libs/libX11/libX11-1.8.1-r10.ebuild')
-rw-r--r--x11-libs/libX11/libX11-1.8.1-r10.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-libs/libX11/libX11-1.8.1-r10.ebuild b/x11-libs/libX11/libX11-1.8.1-r10.ebuild
new file mode 100644
index 00000000..7e1cbddf
--- /dev/null
+++ b/x11-libs/libX11/libX11-1.8.1-r10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX=xz
+inherit toolchain-funcs xorg-3
+
+# Note: please bump this with x11-misc/compose-tables
+DESCRIPTION="X.Org X11 library"
+
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/libxcb-1.11.1[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables
+
+ !<xfce-base/xfce4-settings-4.16.3
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans
+"
+BDEPEND="test? ( dev-lang/perl )"
+
+PATCHES=( "${FILESDIR}"/150.patch )
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ --enable-ipv6
+ --without-fop
+ CPP="$(tc-getPROG CPP cpp)"
+ )
+ xorg-3_src_configure
+}
+
+src_install() {
+ xorg-3_src_install
+ rm -rf "${ED}"/usr/share/X11/locale || die
+}