summaryrefslogtreecommitdiff
path: root/sys-libs/libsepol/libsepol-2.1.9-r1.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-11-21 17:18:13 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-11-21 17:18:13 +0200
commitff58a1945028a65f3f2c543fca4e5ad80135cd38 (patch)
treed5d98962681e666de469eca4ab715a203f9db3fa /sys-libs/libsepol/libsepol-2.1.9-r1.ebuild
parentca3d463b52e6a57350e3bd9e2589448223bdb614 (diff)
Safe keeping the libsepol 2.1 version
Diffstat (limited to 'sys-libs/libsepol/libsepol-2.1.9-r1.ebuild')
-rw-r--r--sys-libs/libsepol/libsepol-2.1.9-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-libs/libsepol/libsepol-2.1.9-r1.ebuild b/sys-libs/libsepol/libsepol-2.1.9-r1.ebuild
new file mode 100644
index 00000000..a64bb63c
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.1.9-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-2.1.8-r1.ebuild,v 1.2 2012/12/30 15:19:13 swift Exp $
+
+EAPI="2"
+
+inherit multilib toolchain-funcs eutils
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20130423/${P}.tar.gz
+ http://dev.gentoo.org/~swift/patches/${PN}/patchbundle-${P}-r1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ EPATCH_MULTI_MSG="Applying libsepol patches ... " \
+ EPATCH_SUFFIX="patch" \
+ EPATCH_SOURCE="${WORKDIR}/gentoo-patches" \
+ EPATCH_FORCE="yes" \
+ epatch
+
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" src/Makefile \
+ || die "Fix for multilib SHLIBDIR failed."
+
+ epatch_user
+}
+
+src_compile() {
+ tc-export RANLIB;
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}