summaryrefslogtreecommitdiff
path: root/sys-kernel/dracut-config-redcore/dracut-config-redcore-1801.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-12 09:34:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-12 09:34:08 +0000
commit6b6f763d1b4603a5a641dfee2ac5b10255219c0d (patch)
treea48a2ca5208d31ef07a343fbc4a60ead082314a4 /sys-kernel/dracut-config-redcore/dracut-config-redcore-1801.ebuild
parent5c851227ce857a995bb1a6141df7791c00d51dbf (diff)
sys-kernel/dracut-config-redcore : version bump, protect the current configuration file
Diffstat (limited to 'sys-kernel/dracut-config-redcore/dracut-config-redcore-1801.ebuild')
-rw-r--r--sys-kernel/dracut-config-redcore/dracut-config-redcore-1801.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-kernel/dracut-config-redcore/dracut-config-redcore-1801.ebuild b/sys-kernel/dracut-config-redcore/dracut-config-redcore-1801.ebuild
new file mode 100644
index 00000000..749c1c2a
--- /dev/null
+++ b/sys-kernel/dracut-config-redcore/dracut-config-redcore-1801.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Redcore Linux Dracut configuration files"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="sys-boot/grub"
+
+S="${FILESDIR}"
+
+pkg_preinst() {
+ # Backup Dracut configuration file
+ if [[ -f ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf" ]]; then
+ cp -avx ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf" ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf.backup"
+ fi
+}
+
+src_install() {
+ # if we overwrite /etc/dracut.conf.d/redcore-dracut.conf we may break users setup
+ # so install the new Dracut configuration file as example only
+ dodir "etc/dracut.conf.d" || die
+ insinto "etc/dracut.conf.d" || die
+ newins redcore-dracut.conf redcore-dracut.conf.example || die
+
+pkg_postinst() {
+ # Restore Dracut configuration file
+ if [[ -f ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf.backup" ]]; then
+ cp -avx ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf.backup" ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf"
+ fi
+}