summaryrefslogtreecommitdiff
path: root/sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 02:33:25 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 02:33:25 +0100
commit58bcc78f748c60135b129c502a2db5175b347c8d (patch)
treeb5ae124e882f2c7d7a61673bf78a6b3f726dd337 /sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r4.ebuild
parent0d631ddf1e0236730ec39d7b9f1f2a2119da30f1 (diff)
sys-kernel/dracut-config-redcore : reenable plymouth
Diffstat (limited to 'sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r4.ebuild')
-rw-r--r--sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r4.ebuild b/sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r4.ebuild
new file mode 100644
index 00000000..e6156600
--- /dev/null
+++ b/sys-kernel/dracut-config-redcore/dracut-config-redcore-1337-r4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Redcore Linux Dracut configuration files"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="sys-kernel/dracut"
+
+S="${FILESDIR}"
+
+src_install() {
+ dodir "etc/dracut.conf.d" || die
+ insinto "etc/dracut.conf.d" || die
+ newins redcore-dracut.conf redcore-dracut.conf.example || die
+}
+
+pkg_preinst() {
+ if [[ -f ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf" ]]; then
+ rm -rf ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf"
+ fi
+}
+
+pkg_postinst() {
+ cp -avx ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf.example" ""${ROOT}"etc/dracut.conf.d/redcore-dracut.conf"
+}