summaryrefslogtreecommitdiff
path: root/sys-kernel/bbswitch-dkms/bbswitch-dkms-0.8-r1710.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-06 18:49:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-06 18:49:42 +0100
commitc70485933fba5f01511a1f600174096ab2125693 (patch)
treeafdb92d6f738c94069a2bd176b096d9ce49e6458 /sys-kernel/bbswitch-dkms/bbswitch-dkms-0.8-r1710.ebuild
parent024c0d9e17ad0be0134bec4d673e4226984786f2 (diff)
sys-kernel : trigger dkms build for the running kernel right away, so one can load the modules without reboot
Diffstat (limited to 'sys-kernel/bbswitch-dkms/bbswitch-dkms-0.8-r1710.ebuild')
-rw-r--r--sys-kernel/bbswitch-dkms/bbswitch-dkms-0.8-r1710.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-kernel/bbswitch-dkms/bbswitch-dkms-0.8-r1710.ebuild b/sys-kernel/bbswitch-dkms/bbswitch-dkms-0.8-r1710.ebuild
new file mode 100644
index 00000000..c29bc74e
--- /dev/null
+++ b/sys-kernel/bbswitch-dkms/bbswitch-dkms-0.8-r1710.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_PN="bbswitch"
+DESCRIPTION="BBswitch sources for linux"
+HOMEPAGE="https://github.com/Bumblebee-Project/bbswitch"
+SRC_URI="https://github.com/Bumblebee-Project/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="amd64"
+IUSE=""
+DEPEND="sys-kernel/dkms"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ # Fix build failure, bug #513542
+ sed -i 's/^KDIR.*$/KDIR\ \:= \/usr\/src\/linux/g' Makefile
+ epatch ${FILESDIR}/${P}-conf.patch
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dodir /usr/src/${P}
+ insinto /usr/src/${P}
+ doins -r ${S}/*
+}
+
+pkg_postinst() {
+ dkms add ${PN}/${PV}
+ dkms install ${PN}/${PV}
+}
+
+pkg_prerm() {
+ dkms remove ${PN}/${PV} --all
+}