summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-3.4.6-r2.ebuild
diff options
context:
space:
mode:
authorCristian Moldovan <cristian@crismblog.ro>2015-06-19 09:18:30 +0300
committerCristian Moldovan <cristian@crismblog.ro>2015-06-19 09:18:30 +0300
commitb81de13a45795842f4d296c2dfff6aab2a9dd97e (patch)
tree039b13059e556a8a7461281b623c903c616318d5 /sys-devel/gcc/gcc-3.4.6-r2.ebuild
parent975d01bc65f0f9190808c0d3cddf3131a790a8f6 (diff)
parent4772dd84c7144b95c0489f25f669006726af8cfe (diff)
Merge pull request #1 from Rogentos/master
Database Update
Diffstat (limited to 'sys-devel/gcc/gcc-3.4.6-r2.ebuild')
-rw-r--r--sys-devel/gcc/gcc-3.4.6-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-3.4.6-r2.ebuild b/sys-devel/gcc/gcc-3.4.6-r2.ebuild
new file mode 100644
index 00000000..d9451f98
--- /dev/null
+++ b/sys-devel/gcc/gcc-3.4.6-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r2.ebuild,v 1.42 2015/05/14 16:47:01 vapier Exp $
+
+EAPI="5"
+
+PATCH_VER="1.8"
+UCLIBC_VER="1.1"
+UCLIBC_GCC_VER="3.4.5"
+HTB_VER="1.00.1"
+HTB_GCC_VER="3.4.4"
+D_VER="0.24"
+
+inherit eutils toolchain
+
+KEYWORDS="-* alpha amd64 arm ~ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
+
+# we need a proper glibc version for the Scrt1.o provided to the pie-ssp specs
+# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
+# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
+# well tested in gentoo on any arch other than amd64!!
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/binutils-2.14.90.0.8-r1
+ amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
+
+src_prepare() {
+ toolchain_src_prepare
+
+ # Anything useful and objc will require libffi. Seriously. Lets just force
+ # libffi to install with USE="objc", even though it normally only installs
+ # if you attempt to build gcj.
+ if use objc && ! use gcj ; then
+ epatch "${FILESDIR}"/3.4.3/libffi-without-libgcj.patch
+ #epatch ${FILESDIR}/3.4.3/libffi-nogcj-lib-path-fix.patch
+ fi
+
+ # Fix cross-compiling
+ epatch "${FILESDIR}"/3.4.4/gcc-3.4.4-cross-compile.patch
+
+ # Arch stuff
+ case $(tc-arch) in
+ amd64)
+ if is_multilib ; then
+ sed -i -e '/GLIBCXX_IS_NATIVE=/s:false:true:' libstdc++-v3/configure || die
+ fi
+ ;;
+ esac
+}