summaryrefslogtreecommitdiff
path: root/sys-devel/gcc-config/gcc-config-1.7.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@rogentos.ro>2016-11-06 12:29:52 +0000
committerV3n3RiX <venerix@rogentos.ro>2016-11-06 12:29:52 +0000
commit0c2a5dcc065cf3321a06051de33cdfac883d6f57 (patch)
tree5814b57ec1bb64a70841079991258be0583cff93 /sys-devel/gcc-config/gcc-config-1.7.3-r1.ebuild
parent28d975103eb6adb2994212b206e8ef0337f7c354 (diff)
force rebuild
Diffstat (limited to 'sys-devel/gcc-config/gcc-config-1.7.3-r1.ebuild')
-rw-r--r--sys-devel/gcc-config/gcc-config-1.7.3-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sys-devel/gcc-config/gcc-config-1.7.3-r1.ebuild b/sys-devel/gcc-config/gcc-config-1.7.3-r1.ebuild
new file mode 100644
index 00000000..a9b9ec1d
--- /dev/null
+++ b/sys-devel/gcc-config/gcc-config-1.7.3-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils unpacker toolchain-funcs multilib
+
+DESCRIPTION="utility to manage compilers"
+HOMEPAGE="http://git.overlays.gentoo.org/gitweb/?p=proj/gcc-config.git"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="+systemd"
+DEPEND="
+ systemd? ( >=sys-apps/gentoo-functions-0.7 )"
+
+src_prepare() {
+ unpacker_src_unpack
+ cd "${S}" || die
+ # systemd-only systems (Kogaion/Sabayon/Redcore) support
+ if use systemd; then
+ epatch "${FILESDIR}/${PN}-systemd.patch"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PV="${PV}" \
+ SUBLIBDIR="$(get_libdir)" \
+ install || die
+}
+
+pkg_postinst() {
+ # Scrub eselect-compiler remains
+ rm -f "${ROOT}"/etc/env.d/05compiler &
+
+ # Make sure old versions dont exist #79062
+ rm -f "${ROOT}"/usr/sbin/gcc-config &
+
+ # We not longer use the /usr/include/g++-v3 hacks, as
+ # it is not needed ...
+ rm -f "${ROOT}"/usr/include/g++{,-v3} &
+
+ # Do we have a valid multi ver setup ?
+ local x
+ for x in $(gcc-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
+ gcc-config ${x}
+ done
+
+ wait
+}