summaryrefslogtreecommitdiff
path: root/net-p2p/gnunet-gtk/gnunet-gtk-0.7.3.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
commit7224c1253228e5c29c78cb3f0f26ce34770f2356 (patch)
tree1684924656132935256e034f35f92abee6623265 /net-p2p/gnunet-gtk/gnunet-gtk-0.7.3.ebuild
Added ebuilds for kogaion desktop
Diffstat (limited to 'net-p2p/gnunet-gtk/gnunet-gtk-0.7.3.ebuild')
-rw-r--r--net-p2p/gnunet-gtk/gnunet-gtk-0.7.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-p2p/gnunet-gtk/gnunet-gtk-0.7.3.ebuild b/net-p2p/gnunet-gtk/gnunet-gtk-0.7.3.ebuild
new file mode 100644
index 00000000..f2688923
--- /dev/null
+++ b/net-p2p/gnunet-gtk/gnunet-gtk-0.7.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# Nonofficial ebuild by Ycarus. For new version look here : http://gentoo.zugaina.org/
+# This ebuild is a small modification of the official gnunet ebuild
+
+DESCRIPTION="Graphical front end for GNUnet."
+HOMEPAGE="http://gnunet.org/"
+SRC_URI="http://gnunet.org/download/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.6.0
+ >=net-p2p/gnunet-${PV}
+ >=gnome-base/libglade-2.0"
+
+src_compile() {
+ econf --with-gnunet=/usr || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} install || die
+}