summaryrefslogtreecommitdiff
path: root/net-im/tox-prpl/tox-prpl-9999.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-10-27 18:38:05 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-10-27 18:38:05 +0200
commit24934e623441310f644e5f72855b0f2bf9f3cd1a (patch)
treea453939bf58199bc2c3ff27bcf0accf2b221c6c4 /net-im/tox-prpl/tox-prpl-9999.ebuild
parent687f45092b4f4ccf33765cee7427f054bae22344 (diff)
Incoming! Moving Rogento.git to kogaion-desktop. Finally
Diffstat (limited to 'net-im/tox-prpl/tox-prpl-9999.ebuild')
-rw-r--r--net-im/tox-prpl/tox-prpl-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-im/tox-prpl/tox-prpl-9999.ebuild b/net-im/tox-prpl/tox-prpl-9999.ebuild
new file mode 100644
index 00000000..b43ef6fc
--- /dev/null
+++ b/net-im/tox-prpl/tox-prpl-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils autotools git-2
+
+DESCRIPTION="Tox plugin for Pidgin/libpurple"
+HOMEPAGE="http://tox.dhs.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/jin-eld/tox-prpl.git"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ net-im/pidgin
+ net-libs/tox"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}