summaryrefslogtreecommitdiff
path: root/net-im/telegram-cli/telegram-cli-9999.ebuild
diff options
context:
space:
mode:
authorAlexe-Cristia Moldovan <contact@crism.ro>2015-06-18 15:22:33 +0300
committerAlexe-Cristia Moldovan <contact@crism.ro>2015-06-18 15:22:33 +0300
commitacc7819462381bc7a0745f4905e84ef00c8b5ed0 (patch)
tree92c856a257f9bd6b1216e3dfe383d41621e6f7a4 /net-im/telegram-cli/telegram-cli-9999.ebuild
parentd73f72e5fce212905ec928d66598735af2375d5c (diff)
add Telegram
Diffstat (limited to 'net-im/telegram-cli/telegram-cli-9999.ebuild')
-rw-r--r--net-im/telegram-cli/telegram-cli-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-im/telegram-cli/telegram-cli-9999.ebuild b/net-im/telegram-cli/telegram-cli-9999.ebuild
new file mode 100644
index 00000000..bd4917a8
--- /dev/null
+++ b/net-im/telegram-cli/telegram-cli-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+EGIT_REPO_URI="https://github.com/vysheng/tg.git"
+inherit git-2
+IUSE="lua"
+DESCRIPTION="Command line interface client for Telegram"
+HOMEPAGE="https://github.com/vysheng/tg"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="sys-libs/zlib
+ sys-libs/readline
+ dev-libs/libconfig
+ dev-libs/openssl
+ lua? ( dev-lang/lua )"
+
+src_configure() {
+ econf $(use_enable lua liblua ) --with-progname=telegram-cli
+}
+
+src_install() {
+ newbin telegram telegram-cli
+
+ insinto /etc/telegram-cli/
+ newins tg.pub server.pub
+}