summaryrefslogtreecommitdiff
path: root/net-im/blight/blight-9999.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2015-08-24 20:47:16 +0300
committerBlackNoxis <steven.darklight@gmail.com>2015-08-24 20:47:16 +0300
commit0c6710a5661dcb9d197d5dc6c5f22aeb03ba583d (patch)
tree2792107df1e29aa284f37a4302b05eed7689b6ed /net-im/blight/blight-9999.ebuild
parent3a33f2966f834d3520b03df59018e3d0295fcc69 (diff)
Revert "[toxcore] adaugat toxcore"
This reverts commit 3a33f2966f834d3520b03df59018e3d0295fcc69.
Diffstat (limited to 'net-im/blight/blight-9999.ebuild')
-rw-r--r--net-im/blight/blight-9999.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/net-im/blight/blight-9999.ebuild b/net-im/blight/blight-9999.ebuild
index 3648b627..ce4a0b83 100644
--- a/net-im/blight/blight-9999.ebuild
+++ b/net-im/blight/blight-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit eutils git-2
+inherit git-2
DESCRIPTION="Cross-platform graphical user interface for Tox written in Racket"
HOMEPAGE="https://github.com/lehitoskin/blight"
@@ -14,22 +14,19 @@ LICENSE="GPL-3"
SLOT="0"
RDEPEND="net-libs/tox
- >=dev-db/sqlite-3.8.6
- >=dev-scheme/racket-6.0.1[X]
- dev-scheme/libtoxcore-racket
- dev-scheme/libopenal-racket"
+ >=dev-db/sqlite-3.8.2
+ >=dev-scheme/racket-6.0.1[X]"
src_prepare() {
+ raco pkg install --no-setup github://github.com/lehitoskin/libtoxcore-racket/master
epatch "$FILESDIR/${P}.patch"
epatch_user
}
src_compile() {
- emake blight
- emake blight-repl
+ emake
}
src_install() {
- emake DESTDIR="${D}/usr" install-blight
- emake DESTDIR="${D}/usr" install-repl
+ emake DESTDIR="${D}/usr" install
}