summaryrefslogtreecommitdiff
path: root/media-tv/popcorntime/popcorntime-0.3.5.ebuild
diff options
context:
space:
mode:
authorStefan Cristian B. <steven.darklight@gmail.com>2014-11-11 15:05:12 +0200
committerStefan Cristian B. <steven.darklight@gmail.com>2014-11-11 15:05:12 +0200
commit9a0650343ab34dcacdb5f6d0f6b2944aa80c352f (patch)
treeb4cdf7b8bb875f0d44193dfea17d30f2c0293ad9 /media-tv/popcorntime/popcorntime-0.3.5.ebuild
parent7c24aaf8fa1f6f8a32cf4cc9005be26969626862 (diff)
parent0fbfeeb062d254d0d3002cbf7cee811f2fb2e130 (diff)
Merge pull request #3 from V3n3RiX/master
Popcorn Time Folks :)
Diffstat (limited to 'media-tv/popcorntime/popcorntime-0.3.5.ebuild')
-rw-r--r--media-tv/popcorntime/popcorntime-0.3.5.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-tv/popcorntime/popcorntime-0.3.5.ebuild b/media-tv/popcorntime/popcorntime-0.3.5.ebuild
new file mode 100644
index 00000000..5bc8a745
--- /dev/null
+++ b/media-tv/popcorntime/popcorntime-0.3.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils fdo-mime multilib
+
+DESCRIPTION="Watch torrent movies instantly"
+HOMEPAGE="http://popcorn.cdnjd.com/"
+SRC_URI="x86? ( http://cdn.popcorntime.io/build/Popcorn-Time-${PV}-Linux32.tar.xz )
+ amd64? ( http://cdn.popcorntime.io/build/Popcorn-Time-${PV}-Linux64.tar.xz )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="splitdebug strip"
+
+DEPEND=""
+RDEPEND="dev-libs/nss
+ gnome-base/gconf
+ media-fonts/corefonts
+ media-libs/alsa-lib
+ x11-libs/gtk+:2"
+
+S="${WORKDIR}"
+
+src_install() {
+ exeinto /opt/${PN}
+ doexe Popcorn-Time libffmpegsumo.so nw.pak
+
+ dosym /usr/$(get_libdir)/libudev.so.1 /opt/${PN}/libudev.so.0
+ make_wrapper ${PN} ./Popcorn-Time /opt/${PN} /opt/${PN} /opt/bin
+
+ insinto /usr/share/applications
+ doins "${FILESDIR}"/${PN}.desktop
+
+ insinto /usr/share/pixmaps
+ doins "${FILESDIR}"/${PN}.png
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}