summaryrefslogtreecommitdiff
path: root/media-gfx/CodeAnalyst/CodeAnalyst-3.4.18_pre0418.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
commit7224c1253228e5c29c78cb3f0f26ce34770f2356 (patch)
tree1684924656132935256e034f35f92abee6623265 /media-gfx/CodeAnalyst/CodeAnalyst-3.4.18_pre0418.ebuild
Added ebuilds for kogaion desktop
Diffstat (limited to 'media-gfx/CodeAnalyst/CodeAnalyst-3.4.18_pre0418.ebuild')
-rw-r--r--media-gfx/CodeAnalyst/CodeAnalyst-3.4.18_pre0418.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-gfx/CodeAnalyst/CodeAnalyst-3.4.18_pre0418.ebuild b/media-gfx/CodeAnalyst/CodeAnalyst-3.4.18_pre0418.ebuild
new file mode 100644
index 00000000..d03a5330
--- /dev/null
+++ b/media-gfx/CodeAnalyst/CodeAnalyst-3.4.18_pre0418.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:$
+
+EAPI="5"
+inherit eutils autotools
+
+DESCRIPTION="AMD Code Analyst"
+HOMEPAGE="http://developer.amd.com/"
+SRC_URI="http://developer.amd.com/wordpress/media/files/${PN}-3_4_18_0413-Public.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="X debug optimization"
+
+RDEPEND=""
+DEPEND="${DEPEND}"
+
+S="${WORKDIR}"/CodeAnalyst-3_4_18_0413-Public
+
+
+src_configure() {
+ insinto "${S}"
+ ./autogen.sh || die "autogen failed"
+ econf \
+ $(use_enable debug) \
+ $(use_enable optimization) \
+ $(use_with X)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc NEWS README AUTHORS
+ find "${D}" -name '*.la' -delete
+}
+