summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-meta/lxqt-meta-0.11.0-r1706.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-06-25 06:42:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-06-25 06:42:33 +0100
commit10d64d4228f8011caa49d8128fc672337664cc6a (patch)
tree8bf64b534c75c603a8817625fb5853cfe4a14647 /lxqt-base/lxqt-meta/lxqt-meta-0.11.0-r1706.ebuild
parentc25a9a8c037c09aecb832af54d4a5826ffd361e6 (diff)
drop lightdm dependency
Diffstat (limited to 'lxqt-base/lxqt-meta/lxqt-meta-0.11.0-r1706.ebuild')
-rw-r--r--lxqt-base/lxqt-meta/lxqt-meta-0.11.0-r1706.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-meta/lxqt-meta-0.11.0-r1706.ebuild b/lxqt-base/lxqt-meta/lxqt-meta-0.11.0-r1706.ebuild
new file mode 100644
index 00000000..a51ae243
--- /dev/null
+++ b/lxqt-base/lxqt-meta/lxqt-meta-0.11.0-r1706.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Meta ebuild for LXQt, the Lightweight Desktop Environment"
+HOMEPAGE="http://lxqt.org/"
+
+LICENSE="metapackage"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~x86"
+IUSE="+about +admin +branding +filemanager +icons +sddm +lximage minimal +oxygen +policykit
+ +powermanagement +ssh-askpass sudo"
+REQUIRED_USE="oxygen? ( icons )"
+
+RDEPEND="
+ >=lxde-base/lxmenu-data-0.1.2
+ >=lxde-base/lxappearance-0.5.5
+ ~lxqt-base/lxqt-common-${PV}
+ ~lxqt-base/lxqt-config-${PV}
+ ~lxqt-base/lxqt-globalkeys-${PV}
+ ~lxqt-base/lxqt-notificationd-${PV}
+ ~lxqt-base/lxqt-panel-${PV}
+ ~lxqt-base/lxqt-qtplugin-${PV}
+ ~lxqt-base/lxqt-runner-${PV}
+ ~lxqt-base/lxqt-session-${PV}
+ virtual/ttf-fonts
+ about? ( ~lxqt-base/lxqt-about-${PV} )
+ admin? ( ~lxqt-base/lxqt-admin-${PV} )
+ branding? ( x11-themes/redcore-theme-lxqt )
+ filemanager? ( >=x11-misc/pcmanfm-qt-${PV} )
+ icons? ( oxygen? ( kde-frameworks/oxygen-icons )
+ !oxygen? ( virtual/freedesktop-icon-theme ) )
+ sddm? ( x11-misc/sddm )
+ lximage? ( media-gfx/lximage-qt )
+ !minimal? ( x11-wm/openbox
+ x11-misc/obconf-qt )
+ policykit? ( ~lxqt-base/lxqt-policykit-${PV}
+ || ( sys-auth/consolekit[policykit(-)]
+ sys-apps/systemd[policykit(-)] ) )
+ powermanagement? ( ~lxqt-base/lxqt-powermanagement-${PV} )
+ ssh-askpass? ( ~lxqt-base/lxqt-openssh-askpass-${PV} )
+ sudo? ( ~lxqt-base/lxqt-sudo-${PV} )"
+
+# Note: we prefer kde-frameworks/oxygen-icons over other icon sets, as the initial
+# install expects oxygen icons, until the user specifies otherwise (bug 543380)
+
+S="${WORKDIR}"