summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-common/lxqt-common-0.11.0-r1710.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-08 18:03:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-08 18:03:40 +0100
commit2d473748ba47a39c9ba689b4957f44ca6e2bd92d (patch)
treee54a85f90e01514c914e29e47ed264849b851444 /lxqt-base/lxqt-common/lxqt-common-0.11.0-r1710.ebuild
parenta383c251e513317adda6662eb6ec849ef25bad49 (diff)
r1710 revision bump
Diffstat (limited to 'lxqt-base/lxqt-common/lxqt-common-0.11.0-r1710.ebuild')
-rw-r--r--lxqt-base/lxqt-common/lxqt-common-0.11.0-r1710.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-common/lxqt-common-0.11.0-r1710.ebuild b/lxqt-base/lxqt-common/lxqt-common-0.11.0-r1710.ebuild
new file mode 100644
index 00000000..86f847ed
--- /dev/null
+++ b/lxqt-base/lxqt-common/lxqt-common-0.11.0-r1710.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt common resources"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+DEPEND=">=lxqt-base/liblxqt-0.11.0"
+RDEPEND="${DEPEND}"
+PDEPEND=">=lxqt-base/lxqt-session-0.11.0"
+
+src_prepare() {
+ epatch "${FILESDIR}"/lxqt-applications-menu-cleanup.patch
+}
+
+src_configure() {
+ local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodir "/etc/X11/Sessions"
+ dosym "/usr/bin/startlxqt" "/etc/X11/Sessions/lxqt"
+}