summaryrefslogtreecommitdiff
path: root/lxde-base/lxappearance/lxappearance-0.6.3-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-18 17:13:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-18 17:13:17 +0100
commit5d12c53a350bf56f89383ec547ca18bdc871bb43 (patch)
tree26955115e62c1b7c6270e591c7310f6de8db1e29 /lxde-base/lxappearance/lxappearance-0.6.3-r5.ebuild
parentf6e20bc6c308556ba296264be68bd88f2ad6bcc8 (diff)
lxde-base/lxappearance : use it for lxqt
Diffstat (limited to 'lxde-base/lxappearance/lxappearance-0.6.3-r5.ebuild')
-rw-r--r--lxde-base/lxappearance/lxappearance-0.6.3-r5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/lxde-base/lxappearance/lxappearance-0.6.3-r5.ebuild b/lxde-base/lxappearance/lxappearance-0.6.3-r5.ebuild
new file mode 100644
index 00000000..23b25251
--- /dev/null
+++ b/lxde-base/lxappearance/lxappearance-0.6.3-r5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="LXDE GTK+ theme switcher"
+HOMEPAGE="https://wiki.lxde.org/en/LXAppearance"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="dbus"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ dbus? ( dev-libs/dbus-glib )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}"/desktop.patch )
+
+src_configure() {
+ econf \
+ --enable-gtk3 \
+ $(use_enable dbus)
+}