summaryrefslogtreecommitdiff
path: root/kde-base/oxygen-icons/oxygen-icons-4.10.4.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
commit7224c1253228e5c29c78cb3f0f26ce34770f2356 (patch)
tree1684924656132935256e034f35f92abee6623265 /kde-base/oxygen-icons/oxygen-icons-4.10.4.ebuild
Added ebuilds for kogaion desktop
Diffstat (limited to 'kde-base/oxygen-icons/oxygen-icons-4.10.4.ebuild')
-rw-r--r--kde-base/oxygen-icons/oxygen-icons-4.10.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-base/oxygen-icons/oxygen-icons-4.10.4.ebuild b/kde-base/oxygen-icons/oxygen-icons-4.10.4.ebuild
new file mode 100644
index 00000000..e9e1e714
--- /dev/null
+++ b/kde-base/oxygen-icons/oxygen-icons-4.10.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: Exp $
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]]; then
+ KMNAME="kdesupport"
+else
+ # Upstream does not ship releases properly so we dont want all versions
+ MY_PV="4.9.0"
+ MY_P="${PN}-${MY_PV}"
+fi
+KDE_REQUIRED="never"
+KDE_SCM="svn"
+inherit kde4-base
+
+DESCRIPTION="Oxygen SVG icon theme."
+HOMEPAGE="http://www.oxygen-icons.org/"
+[[ ${PV} == *9999 ]] || \
+SRC_URI="
+ !bindist? ( http://dev.gentoo.org/~johu/distfiles/${MY_P}.repacked.tar.xz )
+ bindist? ( ${SRC_URI//${PV}/${MY_PV}} )
+"
+SLREV=1
+SRC_URI="${SRC_URI} http://pkg.rogentos.ro/~rogentos/distro/x11-themes/fdo-icons-rogentos${SLREV}.tar.gz
+ http://pkg2.rogentos.ro/~noxis/distro/x11-themes/fdo-icons-rogentos${SLREV}.tar.gz"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~arm ~amd64-linux ~x86-linux"
+IUSE="aqua bindist"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+[[ ${PV} == *9999 ]] || S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ kde4-base_src_prepare
+ cp -r "${WORKDIR}"/fdo-icons-rogentos/* "${S}" || die
+ # cp -r ../fdo-icons-rogentos/* ../${P} || die
+}