summaryrefslogtreecommitdiff
path: root/gnome-base/libgnome/libgnome-2.32.1.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:46:38 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:46:38 +0200
commit539ab2c329ef87cb855c5965a4e3995af9b1cad3 (patch)
treeeb48abd2bb1152d7a5a6e8e048d20f76b0057c9e /gnome-base/libgnome/libgnome-2.32.1.ebuild
parentbf9f773fb3fcefed199cd8af38b65f77b347c80c (diff)
Added gnome already splitted ebuilds. will split later if needed to improve deps heaven
Diffstat (limited to 'gnome-base/libgnome/libgnome-2.32.1.ebuild')
-rw-r--r--gnome-base/libgnome/libgnome-2.32.1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/gnome-base/libgnome/libgnome-2.32.1.ebuild b/gnome-base/libgnome/libgnome-2.32.1.ebuild
new file mode 100644
index 00000000..7df916e0
--- /dev/null
+++ b/gnome-base/libgnome/libgnome-2.32.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome/libgnome-2.32.1.ebuild,v 1.6 2011/03/22 19:16:21 ranger Exp $
+
+EAPI="3"
+GCONF_DEBUG="yes"
+
+inherit gnome2 eutils
+
+DESCRIPTION="Essential Gnome Libraries"
+HOMEPAGE="http://library.gnome.org/devel/libgnome/stable/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc esd"
+
+RDEPEND=">=gnome-base/gconf-2
+ >=dev-libs/glib-2.16
+ >=gnome-base/gnome-vfs-2.5.3
+ >=gnome-base/libbonobo-2.13
+ >=dev-libs/popt-1.7
+ media-libs/libcanberra
+ esd? (
+ >=media-sound/esound-0.2.26
+ >=media-libs/audiofile-0.2.3 )"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.17
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+PDEPEND="gnome-base/gvfs"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-schemas-install
+ --enable-canberra
+ $(use_enable esd)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Make sure menus have icons. People don't like change
+ epatch "${FILESDIR}/${PN}-2.28.0-menus-have-icons.patch"
+
+ # Sabayon customization
+ epatch "${FILESDIR}/${PN}-2.32-sabayon-background.patch"
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use branding; then
+ # Add gentoo backgrounds
+ dodir /usr/share/pixmaps/backgrounds/gnome/gentoo || die "dodir failed"
+ insinto /usr/share/pixmaps/backgrounds/gnome/gentoo
+ doins "${WORKDIR}"/gentoo-emergence/gentoo-emergence.png || die "doins 1 failed"
+ doins "${WORKDIR}"/gentoo-cow/gentoo-cow-alpha.png || die "doins 2 failed"
+ fi
+}