summaryrefslogtreecommitdiff
path: root/dev-python/typer/typer-0.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-23 23:12:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-23 23:12:10 +0100
commit1127717468c0e6b8971d4cf7caf5130cd25abcc4 (patch)
treeaeb3868810e3c53e214441d7af4927dab7f75c1e /dev-python/typer/typer-0.2.1-r1.ebuild
parentd5e31958cc7b0c64b792bf08cc3eb59721cf6ab9 (diff)
dev-python/typer : specifically ask for dev-python/click-7.x (https://github.com/tiangolo/typer/issues/280)
Diffstat (limited to 'dev-python/typer/typer-0.2.1-r1.ebuild')
-rw-r--r--dev-python/typer/typer-0.2.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/typer/typer-0.2.1-r1.ebuild b/dev-python/typer/typer-0.2.1-r1.ebuild
new file mode 100644
index 00000000..9dd40e31
--- /dev/null
+++ b/dev-python/typer/typer-0.2.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2016-2020 Redcore Linux Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Build great CLIs. Easy to code. Based on Python type hints"
+HOMEPAGE="https://typer.tiangolo.com/"
+SRC_URI="https://github.com/tiangolo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ <dev-python/click-8[${PYTHON_USEDEP}]
+"
+
+PATCHES=( "${FILESDIR}"/"${PN}"-avoid-python-dephell-dependency.patch )
+
+python_install_all() {
+ distutils-r1_python_install_all
+}